Skip to content
Все записи в категории 'Реальные случаи неисправностей'

История одного компьютерного ремонта.

Вчера ремонтировал комп (ноябрь 2011).

Это было что-то.

Доделал со второго захода, думал придется делать третий, а ездить туда не ближний свет, но вроде обошлось.

Итак, вначале были симптомы – не работает! Нажимаю включить – зажигается светодиод на морде, а шума вентиляторов нету. Уже странно – никогда такого не было у меня. Посдергивал питание со всего чего можно кроме материнки, посдергивал USB разъемы внутри (иногда бывает, после кривого втыкания флешки коротнет USB разъем и комп не стартует из-зи короткого замыкания).

Симптомы не изменились.

Отцепил разъем блока питания и принудительно перемычкой попробовал запустить. Запускается.

Логически выходит, что материнская плата неисправна – не дает команду на старт, либо блок питания криво реагирует на эту команду, ну или проблемы у него с выработкой дежурного напряжения 5 вольт.

Вскрыл блок питания. (Про то, что все компы – пылесборники, пока не буду много писать. 🙂

Внутри ничего паленого, из конденсаторов маааленькое подозрение на вздутость у одного небольшого: 10 вольт 1000 микрофарад.

Если дело в этом конденсаторе – легко отделались. Забираю блок с собой для ремонта, так как на замену детали нет (а паяльник с собой был, но не возить же с собой целый комп запасной).

Дома проверяю блок с другой материнкой – не стартует, меняю конденсатор и все начинает работать. Через денек еду к клиенту ставить обратно.

Ставлю, компьютер оживает и секунд через 15 отрубается. Я даже в БИОС не успеваю войти! И так раз за разом.

Вот засада!!! Что за фигня???!!!

Стабильность отключения наводит на мысль что гасится он от материнки. Пробую включить и периодически давить reset. В течении минуты выключений нет!

Иногда комп может отрубаться от перегрева – срабатывает защита. Температуру срабатывания можно поставить в БИОСе. Когда жмакаю ресет – видимо БИОС не успевает отработать и проверить температуру. Делаю clear cmos – перекидывая перемычку на материнке около батарейки – произвожу очистку параметров bios по умолчанию.

Включаю, захожу в биос – комп не отключается! Смотрю в разделе HEALTH (здоровье) на CPU Temperature – до скольки же греется процессор? Температура пляшет в районе 60 градусов. Вероятно 60 градусов и стояло как максимальное в bios на защите по перегреву.

Если так всегда было – как же работал комп до того, как накрылся блок питания?

Спрашиваю – в компе до меня копался кто-нибудь? Оказывается ДА.

Снимаю кулер с проца (есть таки любители чистоты, которые термопасту стирают – типа грязно было). Однако термопаста на месте и даже не окаменела. Ставлю все обратно и хорошенько прижимаю кулер перед защелкиванием крепления. Как результат температура съезжает на 47 градусов и держится стабильно. Точно кто-то кулер с процессора снимал до меня, да криво поставил обратно. Ставлю в bios температуру на открючение 70 градусов, выставляю время и загрузку с CDROM и следом HDD0.

Собираю отвертки в надежде, что на этом все. Включаю комп. Загружается.

БАННЕР. Приплыли.

Борьба с баннерами — весч неординарная. Они различаются по навороченности заражения. Однако в последнее время эпидемии стихли, видимо кто-то из детей генералов ФСБ подхватил такое (да наверно не простое) и папочка генерал решил таки навести порядок. А то, что вся страна от этой напасти страдала – им было пофиг. Вобщем за дело взялись поздновато. А точнее, я думаю они были в доле и сами раскручивали баннер-эпидемии, крышевали хакеров и системы смс-платежей. Но потом это перешагнуло все мыслимые границы и только тогда приняли меры.

Короче загружаюсь с загрузочного CD simplix. Хорошо хоть dvdrom живой, атоб вообще кирдык – ничего не поделать. Ищу в папке windows/system32 среди файликов, которые последние по дате и имеют подозрительные имена-расширения. Нахожу userinit.exe. Ищу в профиле пользователя  автозагрузку –

c:\Documents and Settings\ имяпользователя\Главное меню\Программы\Автозагрузка\

там тоже какаято фигня типа VGATRAY и оказалась потом зараженной.

Перемещаю файлики в отдельную папку.

Заодно чищу темп – папку вот здесь:

c:\Documents and Settings\имяпользователя\Local Settings\Temp\

часто вирусы и трояны прямо в темпе лежат и оттуда запускаются.

Перегружаюсь – баннер!

Блин.

Опять гружусь с загрузочного и перед загрузкой подключаю флешку с DRWEB.

Доктор веб обычно не запускался у меня с live-cd, но тут вдруг нормально заработал.

Натравливаю на windows/system32 и Documents and Settings, жду. Находит штук 5 троянов. Если дать полную проверку, я до утра бы там сидел.

Перегружаюсь – ура! Есть рабочий стол! Однако нет иконок и кнопки пуск. Чистый экран и стрелка мыши.

Жму ctrl-alt-del и в меню выполнить набираю explorer.exe

Появляется проводник, но иконок так и нет.

Лезу в реестр – через ctrl-alt-del и меню выполнить – regedit.exe

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

В строке параметра shell написана какая-то фигня а должно быть explorer.exe

Исправляю.

Опять гружусь с загрузочного, нахожу на нем (на загрузочном) userinit.ex_ и оттуда тоталкоммандером распаковываю нормальный userinit.exe в папку windows/system32 (я же оттуда убрал этот зараженный файл)

Перегружаюсь – ура! Есть иконки и пуск. Но цвета какие-то ядовитые. Видимо слетела тема. Захожу в свойства экрана, выбираю классическую тему (самая быстрая и без наворотов) жму применить…

Приехали в очередной раз и кажется надолго. Все черное кроме иконок ярлыков. Ни видно низги! Окна черные, фон черный, текст черный. Окно угадывается только по его контурам, которые загораживают иконки.

Это называется совсем приехали. Звонить кому-то из знакомых в 23 часа вечера, чтоб они, глядя на свой экран сказали мне по телефону как нажимать кнопками (куда жать мышью не видно, хотя указатель виден!)  и таким образом поменять тему? Поздновато уже было.

Опять гружусь с загрузочного. Захожу там в свойства экрана и пытаюсь записать порядок нажатия на TAB и влево вправо, чтоб выбрать другую тему. Однако количество вкладок там отличается (урезанная винда) и поможет ли оно – непонятно. Выясняю только одну полезную вещь. Если что-то наобум изменю, то нажать кнопку прМенить можно комбинацией Alt+М в русской раскладке.

Гружусь в траурный windows. Наошупь делаю правый клик на экране-> свойства (в самом низу появившегося черного квадрата) и там пытаюсь жать tab и вправо влево, периодически нажимая Alt+М. После пяти минут тыканья происходит чудо! Вылетает какой-то другой профиль и все становится красиво!

Ставлю бесплатный антивирус AVIRA, перегружаюсь для проверки – все работает зашибись! Бегу домой.

Давно мне не встречался такой букет неполадок сразу. Это как-же так можно имея банер (без всякой картинки кстати) дождаться чтоб сдох блок питания? Включать каждый день и просто любоваться пока что-то не случится?

Invalid partition table при установке xp

Столкнулся с такой бякой.

Было на винте 2 раздела:
1. Основной (primary) активный
2. Вторичный (secondary) логический

После неудачной попытки поставить на первый раздел винду из образа в виде файла решил поставить винду с нуля, но второй раздел трогать было нельзя — там нужная инфа.

Ставлю xp. Первый проход — раздел есть, быстрое форматирование, копирование файлов, перезагрузка и опять стартует установка как будто винт пустой. Если в это время вынуть диск (должна же уже идти загрузка с винта) то пишет Invalid partition table и все.

Пытался удалять раздел, форматировать полностью, делал fixboot, fixmbr, chkdsk — бестолку.

В итоге нашел на каком-то  старом диске Partition magic загрузочный. Он сразу на старте ругнулся — толи 2 активных раздела у меня, толи два primary, щас точно не помню, но вобщем я согласился внести исправления.

После ребута оказалось, что активен второй раздел — тогда я сделал активным первый — правый клик на нем и найти там SET ACTIVE.

После этого я оттяпал немного места от второго раздела и добавил первому (ато там не хватало постоянно при работе) с помощью программы acronis disk director с диска hirens boot cd

Реанимация windows XP с битым файлом реестра «software»

Принесли комп. Винда не грузится (XP).
Симптомы:
Синий экран и на нем
STOP: c0000218
\SystemRoot\System32\Config\Software и еще кучка текста малозначимая.
Вобщем такая надпись обычно указывает на покоцаный файл реестра, который как раз там лежит C:\windows\System32\Config\Software.

Ну, перво наперво открыл комп и заглянул. Кучка пыли, кулер проца забит наполовину. Пришлось пылесосить.
Сразу заменил также батарейку (при старте компьютер еще ругался что smos checksum error типа. Ошибка контрольной суммы внутренней памяти).
Вспухших кондёров не оказалось ни на матери, ни в блоке питания.

Зацепил жесткий диск через USB-переходник к другому компу (чтоб не грузиться с live-cd) и прогнал скандиск. Ошибок не обнаружилось.

Полез поискать резервную копию реестра в папке System Volume Information.
Черта с два — пусто. Последнее время часто сталкиваюсь с таким, что-то мелкомягкие недостаточно надежной сделали свою винду.

Попытка скопировать файл на свой комп привела к зависанию на несколько минут и потом вышла ошибка — ну короче файл не может быть прочитан. Вероятно какойто сектор записался с неправильной контрольной суммой и винт не мог его прочитать.
С помощью программы R-studio все-таки прочитал файл как мог — явно с дефектами. После чего старый переименовал в Software2 а этот считанный вернул назад вместо него. Хоть он и битый — но он же читается!

Сначала запустил в безопасном режиме — загрузился. Уже радует, так как переставлять винду с нуля не хочется. Настраивать интернет, пароли, мессенджеры — мороки больше.
После чего запустил в обычном режиме — тоже загрузился, но с артефактами — неправильный режим экрана и в диспетчере устройств видео и инфракрасный порт висят с восклицательными знаками (фигасе, откуда там инфракраный-то? сто лет не видел такого — он кстати позже пропал в конце).

После чего была запущена установка windows поверх с функциями восстановления — про это я подробнее писал здесь.

Диск от simplix есть на rutrackers.org и в последнем варианте при запуске есть меню, где русским по белому написано — установка с функцией восстановления.  Там при установке загрузчик видит старую винду и задает такой вопрос –
“Чтобы попытаться восстановить выделенную копию Windows XP нажмите <R>”
После чего windows устанавливается и сохраняет все настройки.

Вот после такой установки «поверх» сразу и дрова встали как надо и все заработало.

Всем удачи.

———— Дополнительная полезная информация от читателя моего блога по имени Алексей———-

Я от такой проблемы избавляюсь проверкой chkdsk с: /f/r/x. бывало что достаточно ее, потом отличная, гениальная утилита rehive, которая цепляется с livecd диска к реальной винде и перестраивает все ветви реестра. если и это не помогает, было что system не восстановился после плохого crc и проверки rehive, то system можно скопировать из windows\repair. достаточно переустановить дрова потом и настроить инет. самое печальное когда сдыхает software, только новая установка.

PS. В каталоге C:\Windows\Repair\ хранится самый первый реестр системы, созданый после(во время) установки windows xp.

© drundel.ru   копирайт типа…

Зависают фильмы при просмотре или перемотке.

Столкнулся с такой ерундой… Видеокарта Geforce 8600GS, какое-то время работала нормально, потом в фильмах стали проявляться затыки при воспроизведении, то картинка застревает то звук затыкается. Может совсем зависнуть, а может повисеть и дальше показывать.  В играх было все нормально (а потом и они стали виснуть).

После долгой возьни, после проверки работоспособности жесткого диска и установки отдельной звуковой карты было выяснено, что фильмы нормально работают, если в свойствах экрана на вкладке диагностика движок «Аппаратное ускорение» сдвинуть влево.
То есть на 1,2 или 3 значении работает а дальше вправо — когда включен режим directX (directdraw, direct3d) начинает зависать.
Поиски по интернету как решить эту проблему результатов не дали. Попытки уменьшить тактовую видеокарты с помошью RivaTuner тоже не помогли. Танцы с бубном вокруг всяких шейдеров, отключения трилинейной фильтрации и прочего не помогли тоже. Ну и новый биос материнской платы не смог помочь.

Поехал купил самую дешевую видюху — GeForce 8400GS. Сразу все замечательно заработало.

Мораль сей басни — если у вас зависают фильмы и видео, а при отключении аппаратного ускорения (Direct3D, directx) все нормально воспроизводится (и если обновление дров не помогает) — не тратьте время, меняйте видеокарту. Скорее всего там или чип отпаялся или накрылось что-то.

Через несколько секунд после загрузки или при загрузке вылетает синий экран.

Столкнулся недавно с такой проблемой. При загрузке выскакивает синий экран, причем уже виден рабочий стол но компьютер не дает ничего запустить — (как-бы еще недозагрузился) и немного погодя синий экран. Ошибки выскакивали разные, но на одной было что-то про ntfs. Точно не помню.

Загрузка в безопасном режиме не работала (приводило к перезагрузке по кругу.)

Было произведено лечение вирусов (собственно они могли при загрузке приводить к такому эффукту — и они были найдено, но оказалось они не виноваты).

После была переустановка windows, которая прошла удачно и как только стал ставить дальнейший софт проблема вернулась.

По ходу обратил внимание на странные щелчки. Загрузился с hirens boot cd и запустил программу MHDD. Она сразу написала что-то типа CATASTROPHIC FAILURE и не захотела работать. После нее попробовал программу VICTORIA — та заработала. Оказалось поверхность жесткого диска читалась неравномерно (винт samsung) местами отлично а местами красно-зеленое поле.

Вердикт — винту кирдык.

Нет ярлыков на рабочем столе…

Предисловие — советую читать до конца, там мой рецепт как решить проблему, если нет ярлычков на рабочем столе.

Вот на днях знакомые поставили антивируса avast, он нашел несколько вирусов, после чего компьютер перестал загружаться. Точнее загружается, а на рабочем столе нет значков ярлычков, нет кнопки пуск, нет панели быстрого запуска. Короче все признаки того, что не стартанул explorer.exe. Попытка по телефону устранить неисправность не удалась — пришлось ехать смотреть.

Итак — рабочий стол без ярлыков. Пуска нет. Жму контрол+альт+дел (Ctrl+Alt+Del) — выскакивает диспетчер задач. Нажимаю в меню Файл-> Новая задача(Выполнить…)


В строке после слова «Открыть:» пишем слово «explorer.exe». Выскакивает ошибка что файл не найден.

Вобщем, загрузившись с LIVE-CD со своей вставленной флешкой (если сразу не вставить то лив-сиди не увидит потом флешку) я скидываю на винт несколько файлов: сам нестартующий файл explorer.exe на всякий случай, сервиспак 3 на windows xp (часто простая переустановка сервиспака решает проблему) и еще утилиту AVZ (скачать можно с сайта z-oleg.com). По ходу выясняю, что их родной файл explorer.exe лежит на месте и никуда не делся. Просто не хочет запускаться.

Опять загружаюсь как обычно, через диспетчер задач запускаю AVZ (странно — запустился) нахожу в нем в меню «Восстановление системы» и отмечаю на восстановление почти все пункты, кроме сетевых настроек. Нажимаю восстановить и после этого пробую опять: (Ctrl+Alt+Del) — диспетчер задач — Файл-> Новая задача(Выполнить…) — «explorer.exe». Опа! Все значки появились и дальше все работало нормально.

Вывод — вирус нарушил в реестре параметры запуска EXE файлов, утилитой AVZ эти настройки были восстановлены.

Итак — решение проблемы.

Запускаем редактор реестра — (Ctrl+Alt+Del) — выскакивает диспетчер задач. В меню Файл-> Новая задача(Выполнить…)  после слова «Открыть:» пишем слово «regedit». Открывается редактор реестра.

Вирус прописал себя в автозагрузку в реестре вот здесь —
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
антивирус вероятно прибьет вируса но запись в реестре не восстановит.
в строке напротив  Shell должно быть Explorer.exe и больше ничего.

Если этого нет — исправьте (правый клик на слове Shell -> Изменить)

Если не знаете что такое реестр  — запустите файлик, который исправит сам —

скачать файл чтоб вернуть ярлыки на рабочий стол.

скачать то-же но в zip-архиве.

Надеюсь помогло.

Села батарейка на материнской плате 1

Позвонил товарищ — компьютер не загружается. На экране ошибка bios checksum error и предложение нажать F1.   Потом выскакивает что-то типа Non system disk or disk error и все. Ну говорю все понятно. Попытался решить проблему по телефону. Говорю заходи в биос , ищи там в менюшках слово boot, а точнее first boot device. Там ставь HDD или HDD-0. Потом нажимаем «Save to cmos and exit setup»  буковку «Y» (yes типа) и «Enter».  Попутно говорю что если комп старый (а он старый) то покупай батарейку новую на материнскую плату типа CR2032. Это такая литиевая батарейка на 3,2  вольта, размером с пятирублевую монету, диаметром 20 и толщиной 3,2мм.

Ну вопчем… не грузится комп все равно. Замена батарейки на следущий день ничего не дала, по телефону мне не видно подробностей, что там на экране творится, пошел смотреть. Винт не виден в биосе… опа на. И вообще крутиться начинает секунд через 20 после старта. Странно.

Оказалось в биосе по дефолту (по умолчанию) отрублен sata контроллер. А раз села батарейка то настройки сбросились. Включили контроллер SATA -> ENABLE  и все заработало. Ато я уже начал думать что винт помер.

Предлагаю задавать вопросы в комментариях про Ваши неисправности. Буду давать советы, что на мой взгляд надо предпринять.